Ongoing issues with app connections
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 17:30 PDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2024 - 15:58 PDT
This incident affected: QuickBooks Apps.com.