Some Apps missing from Appstore
Incident Report for Intuit Developer Group
Resolved
All apps are now showing on Apps.com
Posted Oct 12, 2020 - 15:36 PDT
Investigating
We are seeing issues where some applications are missing from the Appstore.
Posted Oct 12, 2020 - 13:43 PDT
This incident affected: QuickBooks Apps.com.