Sandbox is experiencing degraded performance.
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 09:31 PST
Investigating
Users are unable to connect their app to non-US sandbox companies.
Posted Nov 16, 2023 - 12:00 PST
This incident affected: QuickBooks Sandbox.