Intermittent issue with Intuit Developer portal

Incident Report for Intuit Developer Group

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 12:14 PDT

Investigating

Developers may experience problems with the workspace details, app dashboard and the billing & subscription tab.
Posted Jul 07, 2025 - 11:36 PDT
This incident affected: Intuit Developer Portal.