France Sandbox is not being created from https://developer.intuit.com
Incident Report for Intuit Developer Group
Resolved
This incident has been resolved.
Posted Apr 06, 2017 - 11:53 PDT
Update
The developers should be able to create FR sandbox now.
Posted Apr 06, 2017 - 11:53 PDT
Investigating
Users are unable to create FR sandbox from developer portal.
Posted Mar 27, 2017 - 09:30 PDT
This incident affected: QuickBooks Sandbox.