Partner tier subscription emails sent in error to Builder partners — no actual tier or benefit changes apply

Incident Report for Intuit Developer Group

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 20:27 PDT

Update

We are continuing to investigate this issue.
Posted Jul 10, 2026 - 16:08 PDT

Investigating

Some partners received tier subscription emails in error — current tier and benefits are unchanged
Posted Jul 10, 2026 - 16:02 PDT