QuickBooks Online Edition (QBO) - Invoice
Incident Report for Intuit Developer Group
Resolved
The incident has been resolved.
Posted Oct 15, 2020 - 22:22 PDT
Monitoring
QBO US Customers belonging to one of the QBO Cluster (C71) were unable to view their invoices' status.
Posted Oct 15, 2020 - 21:39 PDT
Investigating
A small subset of QBO Customers are unable to view the status of their invoices.
Posted Oct 15, 2020 - 21:16 PDT
This incident affected: QuickBooks Online API.